QL-820NWB

FAQs & Troubleshooting

FAQs & Troubleshooting

P-touch Editor shows an error message "This application is incompatible with the AirPrint printer driver. Select the CUPS printer driver. Check the FAQ for details." (For OS X v10.8.x or greater).

P-touch Editor does not support the AirPrint printer driver. You need to choose the CUPS printer driver.
To choose the CUPS printer driver, perform the following steps:

 

  1. Choose Apple Menu => System Preferences => Print & Scan / Printers & Scanners.

  2. Choose your Brother machine in the Printers section and check the printer driver in use.
    If [Model name + AirPrint] is displayed for Kind, the AirPrint printer driver is chosen.
    Image

  3. Click the + button.
    Image

  4. Click the Default icon which is located at the top of the dialog box.

  5. Choose your machine from the Name list.

  6. Choose "XXXXXXX + CUPS" from the Use list. ("XXXXXXX" is your model name.)

    If you cannot find "XXXXXXX + CUPS", the CUPS printer driver is not installed. Download and install the latest CUPS printer driver from the [Downloads] section.

    Image

  7. Click Add.
    Image

  8. The printer is now available in the Printers section.

  9. Choose Quit System Preferences from the Apple Menu.

If your question was not answered, have you checked other FAQs?

Have you checked manuals?

If you need further assistance, please contact Brother customer service:

Related Models

QL-820NWB

Content Feedback

To help us improve our support, please provide your feedback below.

Step 1: How does the information on this page help you?

Step 2: €Are there any comments you would like to add?

Please note this form is used for feedback only.