FAQs & Troubleshooting

Close

Innov-is PS500

FAQs & Troubleshooting

FAQs & Troubleshooting

Innov-is PS500

Not your product?

Date: 01/20/2020 ID: faqh00101484_000

"E06" message appears on the LCD.

 

Cause

This message is displayed when the motor locks up due to the problem such as a thread tangle or other reasons.

 

Solution

Clean the race to remove the tangled thread. After cleaning the race, insert the bobbin case properly. If the needle is bent or broken, replace the needle. Then, thread the upper and bobbin threads properly, and continue the operation.

 

 

If the error message "E06" appears in the LCD with the occurrence of one of the following symptoms, follow the procedure below to solve the problem.

 

Symptom 1: The machine rattles and then stops just after sewing is started.

Cause

 

  • The upper thread is not threaded correctly.
  • The thread take-up lever is not threaded.
  • When the machine stops just after sewing is started, the upper thread may not be threaded correctly.
Remedy

 

  • Thread the upper thread again correctly.

 

 

 

Symptom 2: The upper thread is tangled, for example, in the race, or fabric is caught in the machine.

Cause

 

  • Thread is tangled below the needle plate.
Remedy

 

  • Remove the fabric and reset the thread and bobbin.

 

 

 

Symptom 3: The needle breaks, or the needle bends and thus hits the needle plate.

Cause

 

  • You have not used the right combination of fabric, thread and needle.
Remedy

 

  • Choose a thread and needle that are appropriate for the type of fabric.

 

 

 

Symptom 4: The fabric does not feed.

Cause 1

 

  • The thread has become clogged as the stitch is too fine.
Remedy 1

 

  • Lengthen the stitch length.

 

 

Cause 2

 

  • Feed dog is in down position.
Remedy 2

 

  • Raise feed dog.

 

Related FAQs

Related Models

Innov-is NQ550PRW / Innov-is NQ550, Innov-is NQ575PRW / Innov-is NQ575, Innov-is PS500

If you need further assistance, please contact Brother customer service:

Content Feedback

To help us improve our support, please provide your feedback below.
Step 1: How does the information on this page help you?
Step 2: Are there any comments you would like to add?

Please note this form is used for feedback only.