FAQs & Troubleshooting

Close

QL-820NWB

FAQs & Troubleshooting

FAQs & Troubleshooting

QL-820NWB

Not your product?

Date: 04/15/2020 ID: faqp00001421_001

Is P-touch Editor Lite LAN compatible with Mac?

P-touch Editor Lite LAN is not compatible with Mac.
Please download and install the Printer Driver and P-touch Editor from the [Downloads] page.

Related Models

PT-9800PCN, QL-720NW, QL-820NWB

If you need further assistance, please contact Brother customer service:

Content Feedback

To help us improve our support, please provide your feedback below.
Step 1: How does the information on this page help you?
Step 2: €Are there any comments you would like to add?

Please note this form is used for feedback only.