FAQs & Troubleshooting

Close

CV3550

FAQs & Troubleshooting

FAQs & Troubleshooting

Date: 31/01/2018 ID: faqh00100954_000

The machine does not work.

Check for the following matters before requesting service.

If the suggested remedy does not correct the problem, contact your authorized dealer.

 

 

  • Probable cause

    The power is not supplied to the machine.

     

    Remedy

    Make sure that the three-pin plug with the foot controller is correctly inserted into the socket on the machine and that the power supply plug is inserted into a power outlet.

 

 

  • Probable cause

    The power switch is not turned on.

     

    Remedy

    Press the "|" mark side on the main power and light switch on the machine to turn on.
    The LED lamp on the machine will light up.
    If the LED lamp does not light up even though the power and light switch is turned on, contact your authorized dealer.

 

 

  • Probable cause

    The foot controller is not pressed.

     

    Remedy

    The foot controller is not pressed.

    Use only the foot controller that comes with the machine.

 

 

  • Probable cause

    The thread is tangled in the machine.

     

    Remedy

    Remove the tangled thread from the machine.
    Make sure that the handwheel gently turns in a couterclockwise direction with a hand.
    If it is hard to rotate the handwheel by hand, contact your authorized dealer.

 

Related FAQs

Related Models

CV3550

If you need further assistance, please contact Brother customer service:

Content Feedback

To help us improve our support, please provide your feedback below.
Step 1: How does the information on this page help you?
Step 2: Are there any comments you would like to add?

Please note this form is used for feedback only.