FAQs & Troubleshooting

Close

Innov-is A150

FAQs & Troubleshooting

FAQs & Troubleshooting

Innov-is A150

Not your product?

Date: 19/07/2018 ID: faqh00000131_001

"Change to the single needle mode, and replace the needle." appears on the LCD.

 

Cause

This message is displayed when img01 (Twin needle) is set to ON, and a stitch pattern that cannot be sewn with the twin needle is selected.

img02

The icon (Needle position setting) shows whether the needle is in the programmed raised or lowered position and whether the single needle mode or twin needle mode is selected.
For example, the icon img03 in the above screen shows that the machine is set to "Twin needle/down position" mode.

 

 

Solution

 

When you want to sew a pattern you selected :

 

Replace the twin needle with the single needle and set Twin needle settings to OFF in the settings screen as follows.

 

  1. If the twin needle is attached to the machine, replace it with the single needle.
     
  2. Press img04 (Settings key) to display the settings screen.
    img05
     
  3. The first page of the settings screen is displayed.
     
  4. Select img06 (Twin needle) by pressing img07.
     
  5. Change the value of twin needle from [ON] to [OFF] by pressing img08 or img09.

    img10
    (1) img11 : Press this key to move to previous page.
    (2) img12 : Press this key to move to next page.
    (3) img13 : Press this key to select the next item.
    (4) img14 : Press this key to select the previous item.
    (5) img15 : Press this key to change the value of the selected item.
    (6) img16 : Press this key to change the value of the selected item.


     
  6. Press img17 (Back key) or img18 (OK key) to close the settings screen.

 

 

When you want to sew with the twin needle :

 

  • Select a pattern that can be sewn with the twin needle.
    Refer to Stitch Chart on the operation manual to learn stitches that can be sewn with a twin needle.

 

Related Models

Innov-is A150

If you need further assistance, please contact Brother customer service:

Content Feedback

To help us improve our support, please provide your feedback below.
Step 1: How does the information on this page help you?
Step 2: Are there any comments you would like to add?

Please note this form is used for feedback only.