Print  |  Close

HL-2270DW

FAQs & Troubleshooting

FAQs & Troubleshooting

Pre-Required Procedures (Linux)

Pre-required Procedure (1)

Related distributions

openSUSE 10.3 or earlier

 

Related products/drivers

cupswrapper printer/PC-FAX drivers

 

Requirement

"lppasswd -g sys -a root" command is required before the installation.

(Setting the root password is required before you can issue this command.)

 

 

Pre-required Procedure (2)

Related distributions

Ubuntu8.04 or greater

 

Related products/drivers

cupswrapper printer/PC-FAX drivers

 

Requirement
  1. "sudo aa-complain cupsd" command is required before the installation.
  2. "sudo mkdir /usr/share/cups/model" command (as it is) is required before the installation.

 

 

Pre-required Procedure (3)

Related distributions

Debian, Ubuntu, openSUSE, Redhat

 

Requirement

Creating a symbolic link is required before the installation (superuser authorization is required to run the command)

 

For Debian based distributions earlier than Ubuntu8.10, Debian5:
"ln -s /etc/init.d/cupsys /etc/init.d/lpd"

 

 For Redhat based distributions and Debian base distributions greater than Ubuntu8.10, Debian5:
"ln -s /etc/init.d/cups /etc/init.d/lpd"

 

 

Pre-required Procedure (4)

Related distributions

Debian, Ubuntu

 

Related products/drivers

printer/PC-FAX drivers

 

Requirement (superuser authorization is required to run the command)

"mkdir /var/spool/lpd" command is required if the folder does not exist.

 

 

Pre-required Procedure (5)

Related distributions

Debian 64 bit version, Ubuntu 64 bit version

 

Related products/drivers

printer/PC-FAX drivers

 

Requirement

ia32-libs or lib32stdc++ is required to be installed.

 

 

Pre-required Procedure (6)

Related distributions

Distributions that do not have csh or tcsh by default

 

Requirement

csh or tcsh is required to be installed.

 

 

Pre-required Procedure (7)

Related distributions

Fedora 10, 11, 12 64 bit version

 

Related products/drivers

Printer drivers

 

Requirement

glibc.i686 is required to be installed.
(For Fedora 12, nss-softokn-freebl.i686 is also required as a dependency)

 

 

Pre-required Procedure (9)

Related distributions

Distributions using firewall

 

Related products/drivers

scan-key-tool

 

Requirement

The following ports are required to be open.

Inbound direction : UDP Port 54925
Outbound direction : TCP Port 54921

Example of the setting location;

OpenSUSE10.0: Yast-> Security and Users-> Firewall-> Allowed Service->Advanced
Fedora10: System-> Administration-> Firewall-> Other Ports

 

 

Pre-required Procedure (13)

Related distributions

CentOS 7 64bit version

 

Related products/drivers

Printer drivers

 

Requirement
  1. glibc.i686 is required to be installed.
    Command: yum install glibc.i686
  2. Also you require to install policycoreutils-python to use semanage.
    Command: yum install policycoreutils-python
    (However if you cannot install from the above, please type the following command below on the command prompt to check the package of installation.
    Command: yum provides *bin/semanage )
Print  |  Close