When I try to run the P-touch Library, a warning message "A compatible printer cannot be found" appears.

When any printer driver that supports "P-touch Transfer Manager" has not been installed, this issue may occur.
We have released a new version in which the above issue was fixed. Please download and install the latest versions of P-touch Editor.

If you do not want to download the file, press the OK button to close the message and then continue with the operation since the P-touch Library and P-touch Editor are not affected by this issue.

P-touch Transfer Manager is software for transferring data to printers or backing up data in printers.

If your question was not answered, have you checked other FAQs?

Have you checked manuals?

If you need further assistance, please contact Brother customer service:

Related Models

PT-1500PC, PT-18R, PT-18RKT, PT-1950, PT-1960, PT-2100, PT-2110, PT-2300, PT-2310, PT-2600, PT-2610, PT-2700, PT-2710, PT-3600, PT-9200DX, PT-9200PC, PT-9500PC, QL-500, QL-550, RL-700S

Content Feedback

To help us improve our support, please provide your feedback below.

Step 1: How does the information on this page help you?

Step 2: €Are there any comments you would like to add?

Please note this form is used for feedback only.