PR680W / PR680WC
FAQs & Troubleshooting
M2513631 appears on the Artspira app screen.
Error Message
The data could not be downloaded. Please try again.(M2513631)
Cause
Failed to download the data of "Design Templates".
After selecting data on the "Home" screen, the Internet is disconnected when you press the "Create".
Solutions
Please connect your mobile device to the Internet.
If your question was not answered, have you checked other FAQs?
Have you checked the manuals?
If you need further assistance, please contact Brother customer service:
Related Models Innov-is M330E, Innov-is M380D, Innov-is NV880E, PR1055X, PR680W / PR680WC, SDX1200
Content Feedback
To help us improve our support, please provide your feedback below.
Getting Ready Embroidering Operation Accessories Maintenance Network Setting Embroidering Error messages Network Setting Instructional videos My Stitch Monitor Artspira
Error Messages General Question Troubleshooting
Upper Threading Bobbin (Winding/Installing) Threading Needle/Thread/Fabric Before Embroidering How to use (Video FAQs)
Embroidery data Fabric/Stabilizer Embrodery frame How to use (Video FAQs)
Advanced Operation Machine's Settings How to use (Video FAQs)
How to use (Video FAQs)
Cleaning Oiling Maintenance message How to care and maintenance (Video FAQs)
Tips for Network Settings
Problems during embroidering Embroidering result Others
Error Message on Machine's Display
Wireless Network Settings
Getting Ready (Video) Operation (Video) Embroidering (Video) Care and maintenance (Video) Embroidery accessories (Video)
General Question Instructional videos How to Troubleshooting Error Messages