PR670E / PR670EC

FAQs & Troubleshooting

FAQs & Troubleshooting

"Check upper and bobbin thread." message appears on the LCD. What does it mean?

Cause

 

This message is displayed when.

 

Cause 1: the thread tension is too tight.

Cause 2: the upper thread breaks or the thread comes out of the thread tension disc or a thread guide.

Cause 3: lint or dust has accumulated in the thread tension disc.

Cause 4: the bobbin thread breaks or runs out.

Cause 5: there may be another cause.

 

 

Perform the necessary operation according to each solution.

 

 

Solution

 

Solution 1:
Check the tensions of the upper thread and bobbin thread, and then adjust them.
For details, see How do I adjust the tension of the upper thread? and How do I adjust the tension of the bobbin thread?.

 

 

Solution 2:
Check that the thread passes under the upper and middle thread guides, and correctly thread the upper thread.
For details, see How to I thread the machine? (Threading the upper thread).

 

 

Solution 3:
Remove the tension dials, and then remove any lint or dust accumulated between the felt washers.
For details, see Maintenance (Cleaning the thread paths of the upper threads).
 

 

Solution 4:
Check that there is thread on the bobbin and that approximately 50 mm (2 inches) of thread has been pulled out, and then re-install the bobbin.

 

If the bobbin thread runs out, replace the bobbin thread.
If the bobbin thread breaks, reinstall the bobbin and bobbin case correctly.
If the bobbin thread is tangled in the hook, remove the thread jammed and clean the hook.
If the bobbin is scratched or damaged, replace the bobbin with a new one.
If the bobbin case is damaged, replace the bobbin case with a new one.

 

 

Solution 5
Refer to the Why does the upper thread keep breaking? or The bobbin thread breaks.

 

 

 

If your question was not answered, have you checked other FAQs?

Have you checked the manuals?

If you need further assistance, please contact Brother customer service:

Related Models

PR1050X, PR1055X, PR670E / PR670EC

Content Feedback

To help us improve our support, please provide your feedback below.

Step 1: How does the information on this page help you?

Step 2: Are there any comments you would like to add?

Please note this form is used for feedback only.