SDX2250D

FAQs & Troubleshooting

FAQs & Troubleshooting

What Should I do if the Machine cannot be Turned On Correctly? (Machine's LCD Touchscreen Display is not displayed correctly)

 

Cause

If the AC power cord is connected to the machine correctly, the cause is that the machine’s power switch was turned off while updating the machine’s software.

 

 

Check the machine’s LCD touchscreen display and perform the necessary operation.

 

If the LCD display is blacked out and the LED on the right side of the power button is “ON”

⇒ Try to update the machine’s software again according to the following procedure using CanvasWorkspace.

 

 

If the LED on the right side of the Power button is “OFF”, and the LCD display is blacked out

or

If the LCD display is repeatedly changed with white, red and black

⇒ Contact the Brother Customer Service.

 

 

 

 

Solution

For Windows 32-bit, Macintosh or tablet users, contact the Brother customer service or the nearest authorized service center.

 

 

For Windows 64-bit users:

 

  1. Startup CanvasWorkspace on your computer.
    If the CanvasWorkspace isn’t installed on your computer, click here to download the application.

     
  2. Insert the USB cable connectors into the corresponding USB ports on the computer and on the machine.

     
    image (1) USB port for computer
    (2) USB cable connector
     

    A USB cable is sold separately.



     
  3. Check that the machine is on.



     
  4. Click Check for the Latest ScanNCut DX Update… on the Help menu.

     image



     
  5. When the following message appears, click OK to update the software.

    image



     
  6. When the following message appears, click OK to update the software.

    image



    It will take several minutes for the software update to complete.
    The screen remains dark while writing the program, but it is not a malfunction.
    Do not turn off the machine until the update is finished.

    When the update is finished, the machine automatically restarts.

 

 

 

If your question was not answered, have you checked other FAQs?

Have you checked the manuals?

If you need further assistance, please contact Brother customer service:

Related Models

SDX1200, SDX135, SDX2200D, SDX2240D, SDX2250D, SDX900, SDXTL

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