SDX125i

FAQs & Troubleshooting

FAQs & Troubleshooting

E03003 appears on the computer screen.

Error message

Your machine cannot be found. (E03003)
Do not connect two or more cutting machines.

 

 

  • Cause
    Updated the machine’s software when connecting multiple cutting machines to the computer using a USB cable.

     

  • Solution
    Only one cutting machine can update the machine’s software via USB cable.
    Connect only one cutting machine to the computer and try again.

If your question was not answered, have you checked other FAQs?

Have you checked the manuals?

If you need further assistance, please contact Brother customer service:

Related Models

SDX125, SDX125e, SDX125i, SDX225, SDX325, SDX85

Content Feedback

To help us improve our support, please provide your feedback below.

Step 1: How does the information on this page help you?

Step 2: Are there any comments you would like to add?

Please note this form is used for feedback only.