DCP-B7640DW(B)

FAQs & Troubleshooting

FAQs & Troubleshooting

Self-Diagnostic

If the machine's display displays the following self-diagnostic messages, follow these steps:

  • Self-Diagnostic

Cause

  • The fuser unit does not work correctly.
  • The fuser unit is too hot.

 

Action

  • (For a certain model)
    To prevent you from losing the received fax data in the machine's memory, transfer the data to another Fax machine or to your computer before turning off the machine.
  • Press and hold Power(Power) to turn off the machine, wait a few seconds, and then turn it on again.
    Leave the machine idle for 15 minutes with the power on.

If your question was not answered, have you checked other FAQs?

Have you checked the manuals?

If you need further assistance, please contact Brother customer service:

Related Models

DCP-B7620DW(B), DCP-B7640DW(B), DCP-L1632W, DCP-L2600D, DCP-L2625DW, DCP-L2640DW, DCP-L5510DN, DCP-L5510DW, HL-B2100D(B), HL-B2150W, HL-B2180DW(B), HL-L2460DN, HL-L2461DW, HL-L5210DN, HL-L5210DW, HL-L6210DW, HL-L6410DN, MFC-B7810DW(B), MFC-L2805DW, MFC-L2885DW, MFC-L5710DW, MFC-L6710DW, MFC-L6910DN

Content Feedback

To help us improve our support, please provide your feedback below.

Step 1: How does the information on this page help you?

Step 2: Are there any comments you would like to add?

Please note this form is used for feedback only.