Support & Downloads

Linux Informations

FAQ (Printer)



  • I cannot print from RedHat, CentOS.


    Please refer to this link to setup SELinux.
    If you install semanage in advance, Linux-brprinter-installer will be set it up automatically.

    Also you require to install policycoreutils-python to use semanage.
    However if you cannot install from the above, please type the following command below on the command prompt to check the package of installation.

    Command: yum provides *bin/semanage


  • FAQ top



  • The print quality is not good(2).


    Related Distribution:
    Ubuntu 13.04, 13.10(final beta)



    1. Get superuser authorization with the "su" command or "sudo su" command.

    2. Type the following command.



      Command: lpadmin -p (Printer name) -o pdftops-renderer-default=pdftops



      Example:

      lpadmin -p HL3040CN -o pdftops-renderer-default=pdftops




  • FAQ top



  • The print quality is not good(1).



    1. Get superuser authorization with the "su" command or "sudo su" command.

    2. Please open the following file using a text editor.

      /usr/local/Brother/lpd/filter(PrinterName)

    3. Look for "PCL = 1".

    4. Please change that line as follows:

      "PCL = 0"




    5. Related Models:
      DCP-7055,DCP-7057,DCP-7060D,DCP-7065DN,DCP-7070DW,DCP-8070D,DCP-8080DN,DCP-8085DN
      HL-2130,HL-2132,HL-2220,HL-2240,HL-2240D,HL-2242D,HL-2230,HL-2250DN,HL-2270DW,HL-2280DW,HL-5350DNLT,HL-5370DWT,HL-5340D,HL-5350DN,HL-5370DW,HL-5380DN
      MFC-7360,MFC-7362N,MFC-7360N,MFC-7460DN,MFC-7470D,MFC-7860DN,MFC-7860DW,MFC-8370DN,MFC-8380DN,MFC-8480DN,MFC-8690DW,MFC-8880DN,MFC-8890DW

      FAQ top



    6. I print using one-side (single-side) setting for Linux. But The print result is duplex printing.


      The print result may be duplex printing when the setting of the Brother machine is duplex printing.
      Please turn off duplex setting by the control panel, EWS or RPC.


    7. FAQ top



    8. I'm using Ubuntu 12.04. I cannot accurately print at any desired position.


      In the following applications, the printed portion of the page has shifted up, down, left or right.
      Please update following applications with Update Manager.


      • Application

        • CUPS testprint
        • Document Viewer
        • GIMP


      In the following applications and software, you can accurately print.

      • Application

        • LibreOffice Writer
        • LibreOffice Calc
        • FireFox



      • Software

        • PostScript Driver
        • PCL Generic Driver




    9. FAQ top



    10. I cannot print a big letter.


      Please update libfreetype6.


    11. FAQ top



    12. I'm using Ubuntu 12.04. The print quality is not good.



      1. Please open the following file using a text editor.
        /etc/cups/ppd/(PrinterName).ppd

        Example:
        PrinterName : MFC-J615W
        /etc/cups/ppd/MFCJ615W.ppd


      2. Look for the line that starts with *FreeVM: "1700000".


      3. Insert the following line in the next line of that line.
        *DefaultResolution: 600dpi

        Example:

        Before:
        *FreeVM: "1700000"

        After:
        *FreeVM: "1700000"
        *DefaultResolution: 600dpi



      4. Run the command.
        Command:service cups restart


      5. There is PPD file in the following directories.
        /usr/share/ppd

        Example:
        /usr/share/ppd/brmfcj6910dw.ppd
        /usr/share/ppd/Brother/brother_mfcj615w_en.ppd
        /usr/share/ppd/brmfc9840cdw.ppd


        Please edit those files equally.


      6. FAQ top



      7. I'm finding it difficult to install the printer driver.


        We have created a tool to help you easily install the printer driver. Follow these instructions to download and use the tool:

        Note:

        • This tool will install the printer driver automatically, changing the install directories, links and system settings without notice.

        • For USB Users:
          Connect your Brother machine to the PC before starting to follow the instructions.



        1. Click here to download the tool.(linux-brprinter-installer-1.0.4-1.gz, ver.1.0.4-1, 14 KB)
          The tool will be downloaded into the default "Download" directory. (The directory location varies depending on your Linux distribution.)

          e.g. /home/(LoginName)/Download


        2. Open a terminal window and go to the directory you downloaded the file to in the last step.


        3. Enter this command to extract the downloaded file:
          Command: gunzip linux-brprinter-installer-1.0.4-1.gz


        4. Get superuser authorization with the "su" command or "sudo su" command.


        5. Run the tool:
          Command: bash linux-brprinter-installer-1.0.4-1 Brother machine name


        6. The driver installation will start. Follow the installation screen directions.
          When you see the message "Will you specify the DeviceURI ?",

          For USB Users: Choose N(No)
          For Network Users: Choose Y(Yes) and DeviceURI.

          The install process may take some time. Please wait until it is complete.



      8. FAQ top



      9. PostScript data incorrectly appears as text.


        In some distributions, PostScript data incorrectly appears as text.
        To fix the issue, follow these steps:


        1. Set SELinux to "Permissive" mode.
          Or, using "SELinux troubleshooter tool", please change the security policy of SELinux.

          Please make sure the distribution you are using is up to
          date. If it is not, please update and try the print job again. If the problem remains please continue to the next step.


        2. Type the following commands, and look for a "filter(Printer Name)" file.

          ls /usr/local/Brother/lpd/filter*
          ls /usr/local/Brother/Printer/*/lpd/filter*
          ls /opt/brother/Printers/*/lpd/filter*


          One driver has one "filter(Printer Name)" file.


        3. Please open the file you found using a text editor.
          Look for the line that starts with "FILE_TYPE=`file $INPUT...".


        4. Please change that line as follows:

          FILE_TYPE=PostScript


          The line is case-sensitive. Please type exactly as shown.




      10. FAQ top



      11. I cannot install Monochrome Laser Printer driver on Ubuntu11.4(64bit).



        1. Click here to download the patch file.(brdpkgdeldep.gz, ver.1.0.0-1, 323 byte)

        2. Extract the downloaded file:
          Command: gunzip brdpkgdeldep.gz


        3. Please move Linux LPD-driver package and Linux CUPS-driver to the directory that "brdpkgdeldep" file is stored in.

        4. Run the command.
          Command: sudo bash brdpkgdeldep Linux LPD-driver package name
          Command: sudo bash brdpkgdeldep Linux CUPS-driver package name


          The patch will make a new version of the driver and append the filename with the letter "a".
          Example " hl2270dwlpr-2.1.0-1a.i386.deb "


        5. Install the new Linux driver package file (LPR/CUPS) using the conventional method.




      12. FAQ top



      13. I'm using openSUSE11.3. I cannot print to my Brother Machine.



        1. Click here to download the tool.(brother_patch_psconv.gz, ver.1.0.0-1, 593 byte)

        2. Extract the downloaded file:
          Command: gunzip brother_patch_psconv.gz


        3. Run the patch_file.
          Command: bash brother_patch_psconv




        Manually modify:


        1. Type the following command and look for the file which starts with "psconvert".

          Command: ls /usr/local/Brother/lpd/psconvert*
          Command: ls /usr/local/Brother/Printer/*/lpd/psconvert*
          Command: ls /opt/brother/Printers/*/lpd/psconvert*


        2. Please open the found file using a text editor.
          Look for the line starting with "GHOST_OPT=".


        3. Insert "-sstdout=%stderr" before "-sOutputFile" in that line.

          Example:

          • Before:
            GHOST_OPT="-q -dNOPROMPT -dNOPAUSE -dSAFER -sDEVICE=$OUTPUT_TYPE -sOutputFile=- - -c quit"


          • After:
            GHOST_OPT="-q -dNOPROMPT -dNOPAUSE -dSAFER -sDEVICE=$OUTPUT_TYPE -sstdout=%stderr -sOutputFile=- - -c quit"



      14. FAQ top



      15. I'm using Ubuntu 10.04. I cannot print to my Brother Machine.


        NOTE:
        This FAQ is verified using Ubuntu 10.04 Beta 2.
        Operation may differ in the formal release of Ubuntu 10.04.

        1. Users of the following machines need to install csh or tcsh first:

        DCP-110C, DCP-310CN,
        FAX-1815C, FAX-1820C, FAX-1835C, FAX-1840C, FAX-1920CN, FAX-1940CN, FAX-2440C,
        MFC-210C, MFC-3220C, MFC-3240C, MFC-3320CN, MFC-3340CN, MFC-3420C, MFC-3820CN, MFC-410CN, MFC-420CN, MFC-5440CN, MFC-5840CN, MFC-620CN


        2. Please refer to the following four FAQs.




        Or please use the following tool.



      16. FAQ top



      17. I'm using SuSE11.2. I cannot print to Brother monochrome machines.


        For the moment, please use the Foomatic HL1250 driver.
        Linux Ghostscript does not appear to support the bit format conversion. Please check the SuSE community for updates to Ghostscript that may correct this issue.


      18. FAQ top



      19. I'm using Ubuntu. How can I become a superuser?


        Type the following command
        Command: sudo su


      20. FAQ top



      21. What format of the driver can I use for my distribution.


        rpm format driver :
        Fedora, CentOS, Redhat, openSUSE, Mandriva, Acer Aspire one (Linpus Linux)

        deb format driver:
        Debian, Ubuntu, Linux Mint, Asus EeePC (Xandros)


        NOTE: The information above does not guarantee the operation of Brother Linux drivers in all users' operating environments.


      22. FAQ top



      23. I'm using a Linux 64 bit edition. Can I use the Brother Linux printer drivers?


        Yes. Brother printer drivers are created and optimized for 32 bit version of Linux,
        but those can be used for 64 bit Linux also. Some additional steps are required.

        For rpm users:
        1. Install the standard C library for 32bit applications (e.g. glibc.i686(Fedora), libstdc++ for 32bit(openSUSE))
        2. Create some folders if it is required
        2-1. Create /usr/lib/cups/filter if it does not exist.
        Command1: mkdir /usr/lib/cups
        Command2: mkdir /usr/lib/cups/filter

        2-2. Create /usr/share/cups/model if it does not exist
        Command: mkdir /usr/share/cups/model

        3. Install the drivers.

        4. Copy brlpdwrapperXXX files under /usr/lib/cups/filter/ to /usr/lib64/cups/filter/
        Command: cp /usr/lib/cups/filter/brlpdwrapper* /usr/lib64/cups/filter



        For dpkg users:
        1. Install the standard c library for 32bit applications (e.g. lib32stdc++6(Debian) or ia32-libs(Ubuntu))
        2. Create some folders if it is required
        2-1. Create /usr/lib/cups/filter if it does not exist.
        Command1: mkdir /usr/lib/cups
        Command2: mkdir /usr/lib/cups/filter

        2-2. Create /usr/share/cups/model if it does not exist
        Command: mkdir /usr/share/cups/model

        3. Install the drivers using "--force-architecture" or "--force-all"option.

        4. Copy brlpdwrapperXXX files under /usr/lib/cups/filter/ to /usr/lib64/cups/filter/
        Command: cp /usr/lib/cups/filter/brlpdwrapper* /usr/lib64/cups/filter

        5. Copy libbrXXXX files under /usr/lib/ to /usr/lib32/ if /usr/lib32 exists.
        Command : cp /usr/lib/libbr* /usr/lib32/


      24. FAQ top



      25. When I try to print from FireFox or OpenOffice the printer does not print, and eventually displays "Remaining Data" until I press the cancel button.



        Check each configuration tab in the FireFox or OpenOffice print dialog box.
        Some settings can conflict with each other. Look for any alert icons or messages next to the drop down menus, then change the setting to correct the issue.


      26. FAQ top



      27. I want to edit a text file. When I try to save the file, I receive an error message.


        Open the text editor by a superuser.
        Example 1: Get the superuser authorization by "su" command. And run "gedit (filename)"
        Example 2: Run "gksudo gedit (filename)"


      28. FAQ top



      29. I want to use a Brother machine on Acer Aspire-One (Linpus Linux). What driver should I use?


        Use rpm format drivers. Please go to the settings tab to open the terminal.


      30. FAQ top



      31. The printed portion of the page has shifted up, down, left or right.


        Incorrect margin settings can be caused by an incorrect paper size setting.

        1. If you are using OpenOffice (e.g. OpenOffice Word Processor), change the document size in "Menu -> Format -> Page" to match your paper size.

        2. Change the paper size setting from the cups web interface ("http://localhost:631/printers" -> "Set Printer Options")

        3. Edit the paper size parameter in "/usr/local/Brother/inf/br(model name)rc" or "/usr/local/Brother/Printer/(model name)/inf/br(model name)rc" to the paper size.
        ***The available parameter value is in the /etc/cups/ppd/(model name).ppd file.
        ***This action will change the default printout paper size.


      32. FAQ top



      33. I am using EeePC. I can not uninstall the Brother lpr printer driver. The system returns "Segmentation fault".


        Please edit a file before the uninstallation.

        1. Open Console Window from Tools menu in File manager
        2. Run "sudo find /usr/local/Brother | grep setupPrintcap"
        3. Run "sudo chmod 777 (the file found by the command above)"
        4. Open the file with a text editor
        5. Edit "mv $PRINTER_NAME $PRINTER_NAME.tmp" part around 54th line as follows and save the file.

        [Before the edit]
        mv $PRINTER_NAME $PRINTER_NAME.tmp

        [After the edit]
        set +o noclobber
        cp $PRINTER_NAME $PRINTER_NAME.tmp

        6. Uninstall the lpr driver
        sudo dpkg -P (Brother lpr driver name)


      34. FAQ top



      35. I want to use a Brother machine on EeePC(Xandros). What driver should I use?


        Use deb format drivers.
        Terminal Window (Command line interface) is in the Tool menu in the File manager


      36. FAQ top



      37. My distribution uses AppArmor (e.g. Ubuntu, openSUSE) and I can not print.


        Try to change the security software setting for cups to complain-mode (Superuser authorization will be required)
        Command : aa-complain cupsd


      38. FAQ top



      39. I'm using Ubuntu 8.04 or greater. I have installed the drivers, but I am still unable to print.


        Ubuntu 8.04 or greater does not have /usr/share/cups/model directory where our driver create a ppd file.
        Please follow the instruction below when the installation failed with the message.
        (Superuse authorization will be required)

        1. Uninstall the cupswrapper driver.
        Command : dpkg -P (driver name)

        2. Create /usr/share/cups/model directory
        Command : mkdir /usr/share/cups/model

        3. Install the cupswrapper driver
        Command : dpkg -i --force-all (driver file name)


      40. FAQ top



      41. I am unable to print from a client PC to a printer on a print server.


        This problem can occur if you have a firewall installed on the print server. If you have a firewall running, you will have to open ports according to the service you are using.

        LPRng : TCP port 515 (LPD)
        CUPS : TCP,UDP port 631 (IPP)
        Samba/CIFS : TCP,UDP ports 137-139 and 445 (NetBIOS and SMB)


        The procedure to configure the firewall can differ between distributions. For further information, consult the documentation that came with your distribution.


      42. FAQ top



      43. I want to print a text file directly onto letter size paper without using any application. When I print there is a margin problem.


        Find the file "/usr/local/brother/Printer/xxxxx/lpd/filterxxxxx" (where "xxxxx" stands for your model name) and change the 56th line as follows:
        Change:
        A2PS_OPT="--output=- ..."

        To:
        A2PS_OPT="--medium=Letter --output=- ..."


      44. FAQ top



      45. I'm using Gentoo Linux and I receive the following error mssage:" Filter "brlpdwrapperXXXXX" for printer "XXXXX" not available: No such file or directory". (where XXXXX is your Brother product name)


        When you use printer in a Gentoo environment, make a symbolic link to "/usr/libexec/cups/filter/brlpdwrapper[printer name]" after the driver installation.
        Command example (Type the whole command as a single line before hitting enter):
        # ln -s /usr/lib/cups/filter/brlpdwrapper[printer name] /usr/libexec/cups/filter/brlpdwrapper[printer name]


      46. FAQ top



      47. Paper sizes are not listed in OpenOffice when printing with Brother CUPS Wrapper drivers.


        1. Edit the affected ppd-File in /etc/cups/ppd
        2. Go to the "Paper Size" section and add a " " at each PageSize-Line.
        Below is an example:
        *OpenUI *PageSize: PickOne
        *OrderDependency: 30 AnySetup *PageSize
        *DefaultPageSize: A4
        *PageSize Letter/Letter: "                    "
        *PageSize Legal/Legal: "                    "
        *PageSize Executive/Executive: "                    "
        *PageSize A4/A4: "                    "
        *PageSize A5/A5: "                    "
        *PageSize A6/A6: "                    "
        *PageSize Env10/Com-10: "                    "
        *PageSize EnvMonarch/Monarch: "                    "
        *PageSize EnvDL/DL: "                    "
        *PageSize EnvC5/C5: "                    "
        *PageSize EnvISOB5/B5: "                    "
        *PageSize EnvISOB6/B6: "                    "
        *CloseUI: *PageSize

        3. Save the file and restart the CUPS system.


      48. FAQ top



      49. I'm trying to print from OpenOffice, but I cannot print more than one copy of a page, even if I specify more than one copy.


        Please set the number of copies you require and also check the "Collate" box option.


      50. FAQ top



      51. I'm using a Debian based distribution (e.g. Ubuntu, Kubuntu etc). When installing the CUPS Wrapper driver, I get the following error message: "/usr/local/Brother/cupswrapper/cupswrapperXXXX: No such file or directory".


        1. Uninstall cupswrapper:
        1-1. Comment out the lines which include "lpadmin" from:
        /var/lib/dpkg/info/cupswrapperXXXX.prerm
        /var/lib/dpkg/info/cupswrepperXXXX.postinst
        1-2. Uninstall cupswrapper
        dpkg -r cuprwrapperXXXX
        dpkg --purge cupswrapperXXXX

        2. Modify the package:
        2-1. Unpack the package
        dpkg --unpack cupswrapperXXXX.x.x.x-x.dpkg
        2-2. Open /usr/local/Brother/cupswrapper/cupswrapperXXXXX to edit.
        2-3. Look for the line with "lpadmin -p XXXXXX -E -v .......".
        2-4. Change "-m" to "-P" in the line
        2-5. Add the file-path of the PPD file written in the line.
        the file path = "/usr/share/cups/model/"

        Example.
        BEFORE (Type the whole command as a single line before hitting enter).:
        lpadmin -p MFC9420CN -E -v usb:/dev/usb/lp0 -m brmfc9420cn.ppd
        AFTER (Type the whole command as a single line before hitting enter).:
        lpadmin -p MFC9420CN -E -v usb:/dev/usb/lp0 -P /usr/share/cups/model/brmfc9420cn.ppd

        *** if you use Debian and it doesn't have lpadmin, please delete the whole line which refers to lpadmin.

        3. Run the install script

        3-1. dpkg --configure cupswrapperXXXX.x.x.x-x.dpkg

        *** if you deleted the line about lpadmin, access http://localhost:631/printers
        click "Add printer" and follow the instructions to install.


      52. FAQ top



      53. I'm using Ubuntu, I cannot log in to the cups web interface.


        Please refer to the Ubuntu support page below to solve the issue:
        https://help.ubuntu.com/community/PrintingCupsWebInterface


      54. FAQ top



      55. I'm using Ubuntu6.10 or greater. When installing the cupswrapper driver, I get the following error message: "lpadmin:Unable to copy PPD file".


        When you see this error message, you will have to copy the ppd file to the folder where the cups on Ubuntu refers.

        1. Check the ppd file is installed under "/usr/share/cups/model"
        2. Copy the ppd file to "/usr/share/ppd"
        3. Restart cups
        4. Go to "http://localhost:631/printers/" and set the parameters for your printer.
        (If there is no entry of your printer, please go to "Admin" menu and click "Add Printer" and set parameters accordingly.)


      56. FAQ top



      57. I'm using the CUPS 1.2 or later and I cannot print.


        Open the CUPS Web Interface "http://localhost:631/printers" and click on "Modify Printer" next to your machine name entry.
        Click on "Continue" on the next screen and select"USB printer #1" on the next Device section.
        Select "Brother" and "Brother XXXXXX for CUPS", and then click on "Continue".


      58. FAQ top



      59. I want to print using CUPS while keeping SELinux enabled.


        1. Backup the "/etc/selinux/targeted/contexts/files/file_contexts" file before making any changes to the original file.
        2. Check "/usr/local/Brother/" folder to find what folders are under it.

        3-a. If your system has "inf", "lpd","cupswrapper" folders under "/usr/local/Brother", add the following 3 lines to the end of the file ( /etc/selinux/targeted/contexts/files/file_contexts ).

        /usr/local/Brother/inf/.* -- system_u:object_r:cupsd_etc_t:s0
        /usr/local/Brother/lpd/.* -- system_u:object_r:bin_t:s0
        /usr/local/Brother/cupswrapper/.* -- system_u:object_r:bin_t:s0

        3-b. If your system has "inf", "lpd","cupswrapper" folders under "/usr/local/Brother/Printer/[your printer's name]/", add the following 3 lines to the end of the file ( /etc/selinux/targeted/contexts/files/file_contexts ).

        /usr/local/Brother/Printer/(printer name)/inf/.* -- system_u:object_r:cupsd_etc_t:s0
        /usr/local/Brother/Printer/(printer name)/lpd/.* -- system_u:object_r:bin_t:s0
        /usr/local/Brother/Printer/(printer name)/cupswrapper/.* -- system_u:object_r:bin_t:s0

        Note: The part after the doble hyphen can differ between distributions. Please refer the followings to confirm the correct statement for your distribution.

        - For "lpd" and "cupswrapper", the part should be the same as the configuration for "/usr/lib(64)/cups/deamon/.*" in the "file_contexts".
        - For "inf", the part should be the same as the configuration for "/etc/cups/ppd/.*" in the "file_contexts".

        4. Run the command "restorecon *" in the following directories:
        (For step 3-a.)
        /usr/lib/cups/filter
        /usr/lib64/cups/filter <===This is necessary only for 64bit OS users
        /usr/local/Brother/lpd
        /usr/local/Brother/inf
        /usr/local/Brother/cupswrapper

        (For step 3-b.)
        /usr/lib/cups/filter
        /usr/lib64/cups/filter <===This is necessary only for 64bit OS users
        /usr/local/Brother/Printer/(printer name)/inf
        /usr/local/Brother/Printer/(printer name)/lpd
        /usr/local/Brother/Printer/(printer name)/cupswrapper


        5. Restart the PC.


      60. FAQ top



      61. All print jobs are aborted and nothing is printed (1).


        The drivers for your machine may not installed properly, try to create a temporary symbolic link to link the file "/etc/init.d/cups" or "/etc/init.d/cupsys" to "/etc/init.d/lpd" and install the drivers again.

        For rpm users:
        ln -s /etc/init.d/cups /etc/init.d/lpd
        ln -s /etc/init.d/cupsys /etc/init.d/lpd

        For dpkg users:
        ln -s /etc/init.d/cupsys /etc/init.d/lpd


      62. FAQ top



      63. All print jobs are aborted and nothing is printed (2).


        If SELinux is working on your system, some configuration for SELinux is required.
        Please set your SELinux "permissive" or refere the FAQ for SELinux.

        I want to print using CUPS while keeping SELinux enabled.


      64. FAQ top



      65. When installing the LPR driver to use the cupswrapper driver, I receive an error message "/etc/init.d/lpd: not found".


        1. Create a symblic link to /etc/init.d/lpd from /etc/init.d/cupsys or /etc/init.d/cups according your distribition.
        Pre-required procedure (3)
        2. Install the LPR driver again with overwrite option.


      66. FAQ top



      67. My distribution does not support RPM or DPKG installation files.


        Convert the file to "tgz" format using "alien" command on a distribution which is able to handle rpm files or dpkg files (Example: KNOPPIX). You can download "alien" from the following web site.
        http://www.kitenet.net/programs/alien/

        When converting the driver, use the "-t" and "-c" options. When you decompress the tgz file, a module file and an installation script will be created.


      68. FAQ top



      69. If I try to install the driver for multiple machines I get an error message.


        When you install the second driver, please use "--force" option as follows.

        For rpm users:
        rpm -ihv --force xxxxxxx.rpm

        For dpkg users:
        dpkg -i --force-all xxxxxxx.deb


      70. FAQ top



      71. I'm using FreeBSD. Do you have a driver for FreeBSD?


        We do not support FreeBSD. However generic Postscript/PCL driver can be used for Postscript or PCL compatible products.
        If your product is a Laser product, you will be able to use the Ghostscript hl1250 driver or Ghostscript hl7x0 driver.


      72. FAQ top



      73. I cannot print from the GIMP.


        Please check the "Command" section of the GIMP "Setup Printer".
        If the script shows "lp -s -d MFCXXXXXX -oraw", replace it with "lpr -P MFCXXXXXX".
        Please be sure to delete "-oraw ", this is unnecessary option.


      74. FAQ top



Support & Downloads

Others(English)

Others(English)